Yabause
 . Forums . Statistics . Sign Up . Search .

Yabause community forums / Support / command line options?
Author Message
KyJelly
Member

# Posted: 20 Dec 2007 12:24


i was looking through the change log and saw that yabause (windows) supported command line switches. the only one I've been able to find is --bin. i would like a list of the other available one, I'm trying to set it up in my front end and need to be able to load a game automatically. when i tried --bin i don't think it used the correct region because it show some Japanese on the screen and froze there. (shining force 3)

thanks

CyberWarriorX
Moderator

# Posted: 21 Dec 2007 19:46


It -did- at one time. But then I decided to move away from it since the GUI was more up to date. What exactly is missing from the GUI that you need a front end for it?

KyJelly
Member

# Posted: 21 Dec 2007 21:53


loading with --bin does work actually I'm pretty sure. at least it looks like it tries to anyway. the bios loads and the sega logo shows then i get a screen with some Japanese text i can't understand. i checked source forge and it looks as if the feature request is "closed". i guess i thought that meant it was working.

all of my emulators are on a pc that is connected to my big screen hdtv. I load all of them through meedio which gives me box art for selecting each game. almost all other emus allow for sending files to them. my current saturn emu is cassini and it doesn't support cmd line either. so i had to write a script using autoit to load them. i'm more interested in this emu cause it's currently in dev and seems to have more compatibility and speed.

finally while i'm here... in the ini, i manually input 1776x1000 for the res., and it works, but upon exiting yabause the FullScreenWidth changes to 0 all by itself.

thanks

KyJelly
Member

# Posted: 22 Dec 2007 01:59


could use some input on this for my 4 day weekend. i'll be checking back often.

thanks

CyberWarriorX
Moderator

# Posted: 22 Dec 2007 21:53


Well, if I re-add command line options again, it won't be for a while(I just won't have the time). That being said, I'll add it to feature requests .

As for your other problem, I'd need more details as to what exactly you've been doing before it reverts FullScreenWidth to 0. Also which exact version are you using? The latest?

KyJelly
Member

# Posted: 23 Dec 2007 19:41


i'll look forward to it. thanks

the only thing i'm doing is using alt-enter to juggle between full screen and windowed. there are also occasions when i'll drag the window to the center of the screen, but not always. i'm using 0.9.2

KyJelly
Member

# Posted: 24 Dec 2007 02:09


i was able to reproduce the bug. if i go to settings - video then hit OK button it will change 1776 to 0 in the ini. going the the video tab my not be necessary. the 1776x1000 settings are not being shown in the video tab (no values are) so i assume the 0 value is being written for x but it's curious as to why it's not also for y.

CyberWarriorX
Moderator

# Posted: 24 Dec 2007 02:17


btw, are you sure your video card can actually do that resolution? Yabause is coded so it detects all the valid resolution your video card supports. 1776x1000 definitely does not sound like a standard resolution to me.

KyJelly
Member

# Posted: 24 Dec 2007 05:30


i am most certain. i use powerstrip to import a custom resolution that my hdtv can support. it works remarkably well. it's the closest i can get to 1080i without any overscan. it's a mixed bag as to which applications properly detect it but it's about 50%. if the application supports custom res. then it'll work if it's not auto detected. mostly only EA games are stuck at 1280x1024.

CyberWarriorX
Moderator

# Posted: 24 Dec 2007 18:21


Does it list the mode in settings->video->full screen size?

KyJelly
Member

# Posted: 24 Dec 2007 19:22


no it doesn't. not even after i manually put it in the ini. the values are empty.

Hopelessone
Member

# Posted: 12 Jun 2010 15:12


Hi,

Where can i download the command line version? I'm using Ubuntu 10.04 64-bit using Wah!cade as the front end...

Having problems with Package: yabause (0.9.10-1) [universe] because it doesn't support command line parameters...

for more info check:
http://www.anti-particle.com/forum_phpbb3/viewtopic.php?f=2&t=567

Many Thanks..

Hopelessone
Member

# Posted: 14 Jun 2010 03:44


Do you have to compile from source to add command line access?

Thanks..

 


Powered by miniBB forum software © 2001-2011